NY Times Crossword

This puzzle requires Java. If Java is installed and the puzzle is not viewable, you may need to modify your browser preferences.
We apologize, but we are only able to offer a Java version of The New York Times crossword puzzle. It’s best to access the puzzle from your desktop using Safari or Internet Explorer. To play, you must download the Java plugin and make sure your browser is allowing Java. For help, visit Java’s help center.